Process with an ID #### is not running in visual studio community edition 2015 - Coding Sharp

Process with an ID #### is not running in visual studio community edition 2015

Today I was working on a project and my team member has push the changes to repository first time and I get the latest from git. When I tried to run the project I get an error like “Process with an ID #### is not running”. It’s showing Id number different every time.

If I check the error window It showing me an error like below
“The program ‘[3148] iisexpress.exe’ has exited with code -1073741816 (0xc0000008) ‘An invalid handle was specified’.”

In browser it’s shows me message like “The webpage is not available.”

I have tried different different solutions and check but non of them fixed my issue. After googling I found some different different solution and finally 1 solution worked for me.

So let me show you how to resolve that issues in visual studio.

Solution

1. Close all the instances of VS in your PC.
2. Open folder which contains solution file for current project and delete the hidden .vs folder.
3. Again open the Visual Studio.
4. Press F5 and IIS Express should load as normal, allowing you to debug.

 

Note: As per my experience and viewing some kind of solutions over the net, it looks like by moving project from 1 PC to other PC or other environment or Different version of Visual Studio it causes the problem. So there may be some environment specific information available in the .vs folder.